Frame Rate Drops in Eve Online - Partially Solved

Alright, I’m getting massive framerate drops when I move my mouse. A lot of people say that this can be fixed by lowering your mouse report rate -which I tried. Unfortunately, Logitech G Hub doesn’t appear to be actually changing the report rate. I tested it with this online tool, and I still hit up 1k hz.

Update
I uninstalled Logitech G Hub and downloaded the older Logitech Gaming Software (64bit version). I made sure that the toggle switch on the home screen was set to “On-Board Memory” as other people have reported that setting it to “Automatic Game Detection” can also result in the report rating not getting set properly. I was finally able to change my report rate.

Now that I’ve lowered my mouse report rate, I still lose FPS when moving the mouse, however, I never drop below 30 FPS. I still want to stop that frame rate loss (to the best of my knowledge, this didn’t used to happen), but the game is at least in a playable state now. If anyone has any additional info or resources for me to check out, I’d greatly appreciate it.

Anyway, here’s a list of troubleshooting steps that I’ve found (I have tried most of them).

Troubleshooting for Mouse Related Frame Drops

  1. Use DDU to completely uninstall graphics card driver then reinstall it
  2. Use an older graphics card driver
  3. Run as an administrator
  4. Do malware scans (STIJ.exe virus in particular is known to cause this issue).
  5. Try a different mouse (I love my mouse, so this was not a solution for me)
  6. Disable all other HID Compliant devices in the device manager
    • if you accidentally disable your mouse – Alt+Tab to cycle through windows, Tab to cycle through fields/buttons, Enter to make selections
  7. Unplug all other USB devices
  8. Lowering Mouse Report Rate (i.e. via Logitech G Hub)
    • Use this online tool to make sure that the report rate is actually getting set correctly

General Troubleshooting

  1. Use Hardware Monitor to make sure GPU/CPU isn’t overheating and throttling
  2. Disable Full Screen Optimization
    • Open the folder eve\sharedcache\tq\bin
    • Right click the exefile.exe select properties
    • Select the compability tab.
    • Under Settings, tick the Disable full screen optimization.
    • Click apply.
    • Run the game and see if the issue is resolved.
  3. Delete all the logs from your EVE Online documents folder (tens of thousands of files can cause problems)
  4. Verify your Shared cache resource files.
    • Start Launcher
    • Click on open settings.
    • Click on shared cache settings.
    • Click on verify.
  5. Disable all combat notifications / deny all security access to the logs/gamelogs folder. (this was a problem made known to the Devs in late 2018, so it may have been fixed)
  6. Run all monitors at same refresh rate if running multiple clients on separate monitors
  7. Disable Overwolf

How to pause Eve Online