Freesync & VSYNC is working!


(Ravow) #1

Just to let you know that unlike VSYNC, I was able to get Freesync to work properly. I have applied the latest DC patches on my kernel 4.12, rebooted… And now xrandr --prop show:

Freesync capable : 1
Freesync 1.

When I set EVE to interval 1, I get 60 fps, sometime it go lower when I have lot of stuff on the screen or if my face is at 2 meters of a citadel, but still, it go to like 55 or so and still no tearing, not 30 like normal vsync so it’s really Freesync in action!

for now, I tested with open source Radeon with my oced RX480.
My whole gfx chain is bleeding (git-everything).

Unfortunately, it work only in OpenGL… If you try with D3D (Gallium Nine), enabling interval 1 when freesync is enabled produce the same fps as interval immediate.

Also, it work only in real full screen (as freesync does not work on Desktop or Video playback)

EDIT : Using “thread_submit=true” envvar (at the beginning of the last line in the evelauncher.sh), fix it for Gallium nine too!

EDIT 2 : That “thread_submit=true” also fix normal VSYNC (with Gallium Nine)


(Ravow) #2

Got it working on Gallium nine too.

EVE OpenGL Freesync : ± 274W
EVE D3D Freesync : ± 243W

EVE OpenGL Full throttle : ± 400W
EVE D3D Full throttle : ± 405W


(COMM4NDER) #3

Nvidia Gsync also works, though as usual it needs to be the only window and to cover the full screen and disabled compositor, but it works.