Help! can't join chat nor type emails in game

Hi! I’m new in EVE Online. I received an email invitation to join a ‘entry level’ corporation and wanted to join, but i need to get into a chat channel which i apparently joined successfully but can’t see it.
There’s no chat windows.

So i tried to reply the email with my enquiries but can’t seem to type. Whenever I press a key the game freezes for a while and no letters are written into the email.

Please help, thanks in advance

1 Like

Is this just happening in one chat channel, or all of them? If it’s all of them, I guess you could try a reinstall of the game, if logging in and out won’t work.

Welcome to the game by the way! :smiley:


No no no no no no no no no no no no no no no no no no no no no … just don’t. This bunch of ■■■■■■■ is SiCo and is NOT a good start for a new player, You have far better options like: Pandemic Horde, Karmafleet, Brave newbies Inc. EvE university … but DO NOT join SiCo.


Join them!
Work yourself up their ranks!
Then give us access to all the important bookmarks and start killing them from the inside!

■■■■ those guys!

1 Like

I have no time for that ■■■■!

1 Like

Same for me.

But he does. :slight_smile:

Ohh, I see … yes, he should join afterall.

If it is indeed SiCo i also recommend not joining. They have a history of exploiting new bros.

I had an alt that had a chance to join ICANP.

I put an alt in to check them out. There were some genuine leaders in ICANP. Just not the loon at the top.


It’s all of them. Can’t see any chat windows. I thought i was doing something wrong, but apparently it’s something with the game. Any ideas on the typing problem?. Thanks for your answer :slight_smile:

Are the chat windows hidden perhaps? Ctrl tab will cycle through all UI elements that you have open and/or hidden.

If that does not work, you could try to reinstall the game, if you haven’t tried that yet.

Also, the General Issues subforum may be more suited for your question than General Discussion.

(And Nicolai has a good point, take a look at the other newbie friendly corporations. :wink: )

Another thing that came to mind, maybe this is your issue?

Have you tried clearing your cache?

I would love to know how!

Reason why you cant reply in our mail is also most likely that the mail is maxed out in characters. You can remove some of the content and you should be able to type in it again. You can see the character count in the mail and they can cobntain 8000 characters.

Maybe not SiCo itself but ICANP did. And they were under your umbrella until called out by @Knowledgeminer

How are we newbros being exploited ? I’m asking since I’m currently a member of one of the entry level corporations in SiCo and have yet to se anything even remotely resembling exploitation.

Since there’s 0 % corp tax and no mandatory stuff one have to participate in I have a hard time seeing exactly what the exploitation would be.

Now it might be a better choice to join one of the NullBlocs to get out of High-Sec quicker to experience the ‘real’ game but that would be a different discussion unrelated to exploitation.

AFAIK this is not correct. You may not like SICO for a variety of reasons and that’s fine, but exploiting newbies isn’t one of them.

It was ICANP who did that, and you may bet Sabus is out there with a new corp created by a new alt planning to do the same again. So be careful when telling new players to avoid SICO, because you could be inadvertently encouraging them to join whatever the new Sabus newbie harvesting corp could be…


Even after the drama with ICANP i witnessed someone from SiCo using predatory sales tactics in noob system local. He had bought every limited occular implants in the region, relisted at a 400% mark-up and was spamming in local what a great deal it was.