I Cannot See my Own Ship! Can Someone Help Me?

I just started this game and I log in and my ship is invisible. I completely deleted the game and reinstalled it and it is still not there, what do I do? I have not seen a single person in the forums have this problem so far!

Can you show us a screenshot of what you are seeing?

It’s possible that you are simply just zoomed out really far.


I can show you here in a minute but I know for sure I am not zoomed out far because I zoomed max distance in and out and still cannot see it. I can get a screenshot if you want it.


This is almost max zoom in. On almost minimum graphics.

That’s really interesting. If you press Left Alt (default hotkeys) you should be able to see some brackets around where your ship is. Do you see anything of the sort (will likely be found in the center of your screen, or thereabouts.

The brackets look like this. The little “box” on its corner.


There you go

This is max zoom-in btw

What is even more strange is this wasn’t happening yesterday.

Oh wow, that’s interesting. So your ship is definitely there, just not rendered.

My first thought would be to see if a Session Change would fix it. In EVE, a “session change” happens when you perform actions like Docking in a Station, Undocking, jumping through a gate, etc.

I see there a station (the icon is a little square on your Overview, with the type “Caldari Administrativ…” Try clicking on that station, docking, and then undocking. See if that fixes it.

If that doesn’t help, My next instinct would be go and file a bug report / support ticket with CCP over at: https://support.eveonline.com/hc/en-us/requests/new (you may need to log in again), because this seems to be a weird bug where you ship isn’t being rendered properly, even though it is there.


I’ll try that, because I just checked the Fitting thing, and it showed my ship there. I will try that out.

It worked! Thanks a ton for the help!


Does this happen often in Eve Online?

Glad it’s working for you so far! I would go ahead and undock again just to make sure that your ship renders properly when you’re out in space again. (Just in case!)

In my personal experience, this has only happened maybe once or twice in the 6 years that I’ve been playing. I can’t say that I’ve seen it happen often.


Good to know, and yes, it is for sure fixed now.

This is how we learn anyway, now if this ever happens again, I’ll just dock in the nearest place I can find!

1 Like

Fantastic! Glad to see that you can see your ship again!

Fly safe and have fun man!


Thanks! How do I mark this as solved?

I’m actually not too familiar on the functions of the forum. So I’m not sure how to do that.

But I think we can just leave this thread here as it stands in case anyone else stumbles upon it.


Alrighty, thanks again for the help!

1 Like

Good advice to give for new capsuleers :+1:

1 Like

But not so good advice for experienced capsuleers.
Have the same issue. Living on POS in wormhole. So there is no stations to dock/undock. Btw - POS structure also disappeared. The same issue happened with all my characters since the last update.

Jumping through a wormhole or changing ships is also considered a session change…


But shouldn’t it work normally without session change? Maybe after the next update you will need to dance gangnam style for 7 minutes to make it work :rofl:. Is it a bug or a feature? I think it’s a bug and it should be fixed.
Of course this bug is reported and CCP guys kindly promised to fix it.

Yes, it’s s bug. Yes, it will get fixed. The ways listed here allow you to fix it for now.