Is there HOWTO for EVE via Steam on Ubuntu?

Installed Steam, put free EVEonline into my Steam library, clicked Play Game, got

EVE Online
An error occurred while launching this game: invalid platform

What do?

Steam: Activate Proton

  1. Click on the “Steam” > “Settings” menu in Steam.
  2. Switch to the “Steam Play” menu item on the left.
  3. Check the “Enable Steam Play for supported titles” box at the top.
1 Like

Thanks for the good clue, which led me to the recipe that works, which is slightly different:

In Steam, click “Steam” in far upper left corner. This pulls down a menu.

On that pull-down, click “Settings”. This pops up a window whose left panel is a menu titled “STEAM SETTINGS”.

On the STEAM SETTINGS menu, click “Compatibility”. On the right panel activated by that selection, activate the toggle “Enable Steam Play for all other titles”. That pops up a small “Restart Required” window. Choose “Restart” (of course!).

After the restart, navigate the menus again to “STEAM SETTINGS/Compatibility”. Beneath the “Enable Steam Play for all other titles” item, notice a new line titled “Run other titles with:” and a pull-down for choosing amongst versions of Proton.
I tried only the default, which is “Proton Experimental”.

Close the “STEAM SETTINGS” window and click LIBRARY on the main Steam menu

I already had EVE online in my library, so I chose it and clicked Install.

Download takes forever on my ADSL Internet service.

When download complete, click Play, and …

The EVEonline launcher now wants to download 4.3GB. This will take roughly forever on my Internet service.

But so far, so good!

4 gigs is only the beginning. :slight_smile:
Also, Ubuntu seems to take pride in shipping ancient stuff so, especially with AMD videocards, will need updated stuffs.
Search out a significantly newer kernel; something 6.5 or better.
Also mesa 23 or 24.

Thanks! That’s reassuring … kind-of.

I’m running Xubuntu, 22.04.3 LTS.

I think I already have Mesa 23:

$ glxinfo | grep Mesa
client glx vendor string: Mesa Project and SGI
OpenGL core profile version string: 4.5 (Core Profile) Mesa 23.0.4-0ubuntu1~22.04.1
OpenGL version string: 4.5 (Compatibility Profile) Mesa 23.0.4-0ubuntu1~22.04.1
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.0.4-0ubuntu1~22.04.1

Kernel is 5.15.0-94-generic but there seems to be a recipe for installing 6.5.

Don’t plan on trying that until EVE launcher finishes downloading its 4+ gigs.

That’s a good point. Fedora is quite popular for gaming rigs, with their semi rolling release system. I have been using Arch for as long as I can remember, but Fedora would be my second choice for a gaming rig

First attempt to launch EVE, right after the 4+GB download completed, got stuck in Captcha with all four CPU cores running flat out.

Rebooted the machine and it worked … kind-of. Dreadfully slow, all four CPU cores running flat out.

Went to EVE settings, set Optimize for Performance. Did not seem to make much difference.

Guess I should try a newer Linux kernel next.

Thanks again for all the help!