Launcher crash on Exit

Pretty sure this started 2 launcher updates ago, but it works fine until I select Exit from the menu or click the X. The launcher then just freezes and Windows has to forcefully end it. The LogLite utility doesn’t capture any errors or messages at all when this happens, but the Windows Event Log shows the following.

The program evelauncher.exe version 1678.945.655.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 894
Start Time: 01d5f293d254172f
Termination Time: 7
Application Path: D:\Games\EVE\Launcher\evelauncher.exe
Report Id: 38ea5baf-910f-4778-b0b4-27611ca49f3d
Faulting package full name:
Faulting package-relative application ID:
Hang type: Unknown

Got a new launcher update today but still have the same issue.

Anyone else having this problem?

I have the same problem,cannot close the launcher anymore and have to use “Close the program” option from Windows. It started yesterday. Also it doesn’t happen everytime and I have no clue what triggers this behaviour.

Same issue on my Mac. Have to use Force Quit to get rid of the launcher.

I too have to force quit. When I use task manager it says eveonline 32 bit, the game is 64 bit only and I’ve been using 64 bit for months when it was optional.

Yup! Same problem for me as well! Cannot exit the normal way, I can usually exit if I have run it in administrator mode, but after some testing tonight, that seems to be hit and miss.

Things I’ve tried:

Standard operation, standard way of closing launcher
Tried standard way on an alt account on windows
Tried Admin mode on both windows accounts
Tried in safe mode

All seem to result in the launcher not exiting properly.

Hope this helps!

The launcher not close normally. Need to force close it. Strings in the launchelog-xxx.txt when Exit is pressed:
default debug Exited main event loop
default debug Waiting for event logger to finish

i have same problem.

if the launcher did not quit windows can not turn off unless press shut down anyway.

Because of this launcher crashing issue, you cannot shut down your PC normally until you end process or shut down forcefully.

First time I had no idea I just gave shutdown command and left the PC only to find it still running 1 hour later. It’s not a big deal, but it’s an inconvenience. Hopefully people at CCP are aware and will fix this issue soon.

Confirm same issue.
Can close launcher only via task manager

Likewise here… must Force Quit on my Mac

Same here, have to Force Quit on my Mac. However, on my Windows 10 machine it quits normally just fine.

Same issue on my machine. Have to force close through Task Manager and it prevents normal shutdown. Started a couple weeks ago I think? Not game breaking but annoying.

Windows 10 Home
Version: 2004
Build: 19041.153

AMD Ryzen 5 3600
Nvidia GeForce RTX 2070

Same here. Must force-quit on Mac and Windows.

Well the launcher update which came through yesterday seems to have resolved this for me. For the moment anyway.

Today the launcher has been updated. The problem has not been resolved, the problem has changed ¬_¬

Lines in the log file when Exit is pressed:
2020-03-26T15:12:04.835Z default debug EVE Launcher closing, 0 client(s) still running
2020-03-26T15:12:04.835Z default debug Web shutdown - Starting
2020-03-26T15:12:04.843Z default debug Web shutdown - Finished
2020-03-26T15:12:04.843Z events debug Queueing eve_launcher.Shutdown : xxxxx
2020-03-26T15:12:04.843Z default debug Closing main window
2020-03-26T15:12:04.843Z default debug “{\n “processes”: [\n ]\n}\n”
2020-03-26T15:12:04.845Z default debug Closing WebGui
2020-03-26T15:12:04.853Z default debug CustomWebPage destructor done
2020-03-26T15:12:04.862Z default debug Minimizing to tray rather than closing fully
2020-03-26T15:12:04.867Z default debug Destroying WebGui
2020-03-26T15:12:04.873Z events debug Shutdown timer started
2020-03-26T15:12:04.873Z events debug Channel setup
2020-03-26T15:12:04.873Z events debug Channel ready. Setup duration: 0 seconds
2020-03-26T15:12:04.873Z events debug Sending eve_launcher.Shutdown : xxxxx
2020-03-26T15:12:04.873Z events debug Publishing succeeded eve_launcher.Shutdown : xxxxx
2020-03-26T15:12:04.873Z events debug Event Queue empty, shutting down

The launcher interface closes, but the process remains in memory. You need to open the Task Manager and manually close it.

Line in the log after force close:
2020-03-26T15:13:08.141Z default debug EVE Launcher closing, 0 client(s) still running

UPD: The launcher does not close, the launcher is minimized to tray instead of completely closing.

Same here. I have to Force Quit the launcher on Mac OS Mojave. I reinstalled, cleared cached, and so on, but nothing fixed the issue.

According to the launcherlog it gets stuck at “Waiting for event logger to finish”

2020-03-07T23:38:35.828Z default debug Finished task “Patch info downloader for Tranquility”
2020-03-07T23:38:35.828Z default debug CustomWebPage(0x60000318d650) “setClientVersion(‘tq’, 1678293)”
2020-03-07T23:38:35.828Z default debug Build on “tq” : “1678293” - public
2020-03-07T23:38:35.828Z default debug “tq” : Build is unchanged
2020-03-07T23:38:35.828Z default debug CustomWebPage(0x60000318d650) “updateProgress(‘tq’, 1, ‘Ready’)”
2020-03-07T23:38:35.829Z default debug CustomWebPage(0x60000318d650) “setPlayable(‘tq’, true)”
2020-03-07T23:38:35.829Z default debug onEndUpdate for tq changes: false
2020-03-07T23:38:35.829Z default debug refreshServers “tq”
2020-03-07T23:38:35.829Z default debug refreshServers done
2020-03-07T23:38:35.829Z default debug Last verify time: QDateTime(2020-03-07 18:34:10.525 CET Qt::LocalTime)
2020-03-07T23:38:35.830Z default debug “Scheduling refresh after 15 minutes”
2020-03-07T23:38:35.834Z web debug info: Setting playable value as true for tq
2020-03-07T23:38:40.544Z default debug Exited main event loop
2020-03-07T23:38:40.544Z default debug Waiting for event logger to finish