Native Mac Client Playtest - Known Issues

Hi. Exefile is the name of the EVE Client. I would love to get this changed…but there is a lot of pain in doing so :slight_smile:
In the future, the Eve client will look more as you’d expect on macOS (A image with the game name) in the dock.
You can check if you’re running the native client by bringing up the FPS counter and looking for ‘metal’ as the renderer in the bottom left corner of that window.

I see!

I just checked and the FPS counter says its using “metal”, so I guess the issue is my old computer.

Thanks for your time!

1 Like

Good Morning all,

As an Update I know that CCP might still be working of the Fleet Issue, but as for now/today fleets are still not working. I was able to send an invite but my other Account never gets the invite/message to join.

Thank You

Hi. Thanks, it is fixed internally. Tomorrow is the last day of the Native Client Test, so the next version on Sisi may have the fix included.

Hello folks,
I know, this is the issues thread, but I have to say that the native Mac client is the best thing that has happened for EVE for a very long time. I was really looking forward for this since the first announcement. And it’s working great. The native client fixed a number of issues I had before:

  • switching sound from speaker to headset via bluetooth now works seemlessly without the need to restart audio
  • no more flickering sound in the eve client when using bluetooth headset while an Teamspeak
  • great graphics and overall performance, making a switch to neweer hardware obsolete
  • using default keyboard shortcuts as they are mentioned everywhere, e.g. alt-r really opens the market instead of cmd-r or pasting something into the client via cmd-v no longer opens the activity tracker and so on

I did notice only one minor flaw: I often do use q-clicking to navigate in space. When I press the q key, I do get that circle around my ship, try clicking with the mouse button, but the position I clicked to does not get locked in, in fact nothing happens. Might be a minor bug.

Overall: this really is great work, CCP. Thank you very much for making this happen.

Kind regards

1 Like

When you are using autopilot - the next gate doesn’t show in the selected item window - it was weird, I was in lowsec and it worked, as soon as I jumped to nullsec it stopped populating with the next gate.

Uggh, OK, so I typed this and then the next gate it worked fine - so I dunno - it is inconsistent

For the changing UI scaling affecting offset picking -

This happened to me but only in windowed mode - once I went back to full screen it stopped

The playtest has now come to an end.

A huge thank you to everyone who has provided feedback. We have gathered a significant amount of data, both from the forum and bug reports. More than we expected at this stage!

There won’t be much new news for a while, as we’ll be acting on the data we’ve gathered here and continuing the normal development of the Native Mac Client. We may have another playtest in the future, so keep an eye on our normal places: News Articles, Forum, Email and social media :slight_smile:

1 Like

FYI, that is a known issue in TQ on both Windows and Wine-emulated versions of the EVE client. Routing gate selection has been buggy for ages - and it is completely random as far as I have been able to tell.

11.2.3 here. I also have wine launching. Verified via Activity Monitor.

The test is over and Sisi is back to using the Wine launcher.

Sorry for the late addition… my FauciOuchie was a bugger, finally dug up screenshots.

Aside from the readability issues discussed above, I found you could create many shenanigans by enabling Sidecar. Connecting an iPadPro as a second display and dragging EVE to the extra screen gives you some curious menu behavior:


This behavior persists even if you swap the window back to the main screen.