Nothing to see here. Please disperse. Nothing to see here

Meh, I’m just going to delete it. My post was based on information that was both out of date and erroneous.

Don’t I feel like an ass.

4 Likes

Obligatory tagging of @Zoiie

1 Like

lol. I figured no tagging was necessary.

1 Like

My entire IT career started with Slack. Going through my Gentoo phase ending with Mint.

And I am now a full MS shop. It just work better for what I need it for, in corporate and my personal use. If you would have asked me if I would go full MS stack I would have said you are bloody mad.

I got no issues with windows, for every item you lists is an issue, people could do the same with Linux. I had to let go of my perceived opinion about something and do things that is in the interest of my organization and me personally. And I am sure CCP is weighting that as well… does the amount of Linux players actually justify the potential development time and costs that would be needed? Not to mention the support and services costs of that as well.

5 Likes

Those comments from CCP were quite a while ago.

I’m not changing from Linux to another os. There are plenty of games that do work on Linux to satisfy my entertainment needs so they will get my dollars. If a game doesn’t work on Linux I don’t bother buying it. If it stops working on Linux I no longer play it. For example the last time I played rust was the day before they made it no longer work on Linux. Same for elder scrolls online. (I hear ESO might work once again but I never bothered to come back)

The same will be for Eve. I’m not dual booting just to play Eve. If Eve no longer has a way to work on Linux then it will be Eve that gets the boot. That doesn’t mean CCP has to necessarily “support” Linux. Really all they have to do is not actively get in the way of it working.

The problem is that in CCP land something like the launcher, which has no value whatsoever gameplay wise becomes the main reason that the game won’t work. Pretty sad really. I’ve been using a launcher from more than a year ago and cancelling the update every time I log in because I just don’t want to bother having to deal with a roll of the dice. When I come to play I want to get into the game not have to debug or reinstall the launcher.

Dev time wise, something as mundane as the launcher should be extremely easy to make work on multiple platforms. There just isn’t much to it.

But a working launcher is just too much for CCP to deliver most of the time. So yes, eventually Eve on Linux is doomed.

5 Likes

Only when the nerds give-in.
I can’t see that happening quickly although it may well be if they twig-on-to what the linux foundation is up to. For a long time linux could claim moral superiority. The system no-longer can.

In war, three-quarters turns on personal character and relations; the balance of manpower and materials counts only for the remaining quarter.
~ Napoleon Bonaparte August 27, 1808 at the palace of Saint-Cloud

PClinuxOS is a GUI-easy thing that will readily dual-boot Bill’s Bane™ for gaming if needed.

https://www.pclinuxos.com/

EDIT: I should have said it will readily dual-boot windows if one already has windows on that machine. PClinuxOS doesn’t install windows.

2 Likes

care to elaborate?

@Xuxe_Xu
Thanks. I’ll check it out.

Bit dramatic title.

tl;dr the article is wrong, Bartenders assessment is wrong, It was a one line fix in wine, everything is fine

I have played EVE on Linux for over a decade. Actually I never played it on Windows ever, because my last Windows was 98SE. The supported client was absolutely horrible, I used it for a week or so before switching to wine. The Snorlax Launcher was nice, but was soon abandoned, and it became cumbersome to install and update DXVK manually in the prefix, so I witched to wine again.

So for the whole time I was playing EVE, the working solutions came always out of the community.

Now, about the whole CCP Bartender quote that seems to cause the whole drama. The thread with the quote can be found here New launcher... new Linux error?

I’m not sure how he made the assessment when saying that. Probably because this is what they changed and then he just assumed wine doesn’t support it. He was completely wrong. Even a quick glance at the wine sources showed that this functions where in fact implemented.

You can find the whole history in the thread. Some people found out very quickly, even before Bartender wrote that it still worked with older wine versions. Bartender shrugged this away as some quirk that will soon stop to work.

What essentially turned out to be the issue was if I can recollect that correctly, the crypto lib CCP was using relying on some undocumented behavior and using a lib they don’t explicitly load. Wine has a similar behavior but it was changed a while back and that is why older versions still worked. Since this was a regression and wine is about emulating even the undocumented quirks this was reverted again.

https://bugs.winehq.org/show_bug.cgi?id=51465
https://source.winehq.org/git/wine.git/commitdiff/2b3a300cbfee15dd6771a0a984c13591a2b36358

Within a week the patch was in a new wine release and the Launcher was working again.

So here is what Linux Community Support looks like:

  • Launcher broke on Linux
  • Within a day we had 3 different workarounds, pick one and you can play again.
    • Downgrade wine to older version
    • Use the old Linux Launcher or downgrade the Windows Launcher
    • Play on Steam and use Proton 5.0
  • Within a week @Renard_DuGaulle and @Lycan_King_Tawate debuged and fixed the issue in wine
  • Within two weeks the fix was in a new wine release and everything was working again

So this kind of thing isn’t a one time event, I have seen something like this play out multiple times over the years. The Linux community can support it self, thank you very much. The only thing the community asks of CCP is to not intentionally make this more difficult than it has to be.

Another thing that came out of this is a fix to an upstream library CCP uses that caused the initial issue. An interesting read if you are curious how responsive CCP is to those things: Load msvcrt explicitly when not loaded by Algebro7 · Pull Request #1062 · weidai11/cryptopp · GitHub

8 Likes

I had (past tense!!!11111eleven) the same issues with the windows EVE launcher and after breaking some dependencies, I managed to get wineHQ 7.0.1 to work and voilà - now the windoze EVE launcher launches EVE Online - with Vulcan™.

Anyhow, if CCP likes to “remove” the support for Linux, they should remove the support for UNIX altogether as well - nobody needs it.
Whatever could go wronkhhhh.

Should be moved to OPE as it’s nothing more than rant on windows.

To be fair the post was done in Jul/21, the issue happened.

Dunno why @Shipwreck_Jones posted this, I can offer you all a solution to your anxiety … Uninstall. And don’t thank me, it’s my share of public services, I did it and I’m FINE!

Creating post after post is not going to help.

This should be locked and moved to linux section, this is uninformative and outdated. The problem was fixed thanks to our EVE linux heroes.

I’m not one to defend CCP, but it’s not their fault, they opted for more security and wine was not ready to deal with it. Move on…

GG

Oh, I didn’t know it was fixed. Thank you for the update.

Well, don’t I feel like an ass.

1 Like

Moved to the OOPE section.

Fly safe o7

ISD Bahamut

2 Likes

Don’t! how should you know? Few people get so lost that they siddenly find themselves in the Linux forums, let alone read what is happening there :smile:

4 Likes

I decline. Not really one to repeatedly tap on a political powder keg.

1 Like

Great response, thanks. I’m a less-than-technical Linux user, and your post made me go look at Steam again. Turned on Proton and boom, up and running. Bypassed some issues I was having with CCP Snorlax’s old launcher, and Lutris giving me fits. Thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.