Old Launcher Deprecated from 7 February 2024

What I hate the most about the new launcher at the moment : too stupid to update itself automatically when idle. At different time of the day, if I’m switching characters (they’re not all omega), I’ll have the Play Now button available so I’ll click it for the account(s) I want, then the launcher will turn Not Ready and will update. As it does so, the client I had launch actually cancels and I have to wait for the update to finish to click Play Now on the same character(s) I tried seconds to a minute ago.

That is just under a minute extra waiting, sure, but it is freaking annoying as it happen so often at any time of day, multiple times in the day. Why can’t the launcher update itself when it is idle? And it should be independant from the currently opened clients.

Get used to it, it seems to update all the time.

To improve the launcher from ti’s weakness, it has to be said. Shutting the f* up about it or any weakness won’t help fix it. The launcher doesn’t have to wait until the players interact with it to update. It should be able to update automatically when the update is available.

I became inconvenient, it is not clear in what system my character is loaded, you need to enter the game as a character, then go to the character selection menu already in the game, and only then I get the opportunity to see where are my characters account.

Just lost overview settings on some characters, lost all settings on one (chat channels, the lot) honestly this is simple stuff, how a launcher can break the game it launches is beyond me. I even tested the launcher in beta and didn’t have this issue. It seems that the release launcher was different to the final beta launcher, whats the point in testing it then?

1 Like

After a thousand threads and posts on that topic, people are still either too lazy to read or too lazy to look through the launchers options to reactivate the launch to the character selection screen…

1 Like

If only that were close to being the only or worst thing about the launcher.

A new one - it’s display only, but it shits me.

You create a launcher group. Let’s call it “Friends of Bob”. you add the character, you get to choose if a character is booted to straight away or if it should go to the character selection screen, all good.

And then you go back to the main launcher page, and there’s your shiny new launch group. Called “friends of bob”.

There’s also things like the “click and hold” process to launch a specific character requires that you “click, hold and release”. The fact that the Vanguard icon stored under each account acts differently to every other icon in the same area of the interface. The fact that the launcher self-closes after a period of inactivity (which then seems to stop updates) - oh, and if you try to start it again too quickly at that point, it spawns new instances in memory, but none of them will actually run on screen - so you have to go to the tray area and close each instance before you can actually use the launcher). The launcher’s so slow at checking for updates when you do start it that it’s actually possible to launch at least two clients before it goes “oh, ■■■■, update”, and then it blocks starting new clients - leaving the unpactched clients it let start still running until you close them down). Etc.

And that’s just the bugs I’ve found running the new launcher for only two play sessions. Imagine if I’d actually had say eight hours to run tests and try the thing fully to see what else I could break. Like if I was a QA or test engineer, or even a development team leader for the team responsible, before I agreed to hand it to QA for further testing prior to release…

Is there a particular reason the correct platform path separators are not being used?

Everything was working fine until the new launcher. Now I am just staring at the splash screen. I would assume that its downloading something, but eth0 is hasn’t budged much from 200 Mbyte since restart 20 minutes ago.

But after you undock you can fly about?

Say that again after CCP updates your boot.ini

2 Likes

https://binaries.eveonline.com/EveLauncher-2410154.exe

What do you mean by “correct”? Windows API has introduced it at some point to accept both forward and backward slashes.

1 Like

Since the new launcher has been released:-

MacBook Pro (2017) No longer launches ( failed validation check ) gg ok, you hate OSX 10.14, I knew that
Linux ( Pop OS ) New Launcher (hangs on load) ok, linux not supported

Today?

MacBook Air M1. Steam install. This worked last night when I went to bed.

Back to being my own tech support instead of playing eve. :frowning:

Just to confirm, the issues you’re encountering (screenshot) are on the MacBook Air M1?
Does the issue persist if you uninstall via Steam and re-install the game?


There are several Linux users, that participated in the early beta, and can be found both in the Linux section of the forums and in the official EVE Online Discord. They may be able to provide you with some guidance regarding getting the launcher/game running under those environments.

On discord: “Linux thread - Here be dragons

Double check graphics options. Not all of them are migrated with launcher profiles migration.

1 Like

It was introduced WAY before Windows became a thing.
It was in the specs since DOS 3.3 the least I can check.

Totally pissed I had a Venture off Home. With 10million as an Alpha, after the launch upgrade I was in a capsule maybe 30 jumps from home. If I was an Omega I would be suing for compensation, these actions without warning dont make me condusive to pay anything monthly on Omega. Untill I see some worthwhile gameplay on Alpha as a fighter Or A miner because Im not able to collect gas. I will not be paying a penny,

Makes no sense what you just said. Unless you logged off in space, and upon logging in, you were caught, podded and sent to your med clone which sounds like you didnt update it where you currently live

OLD LAUNCHER was very FUNCTIONAL

“TREE PORTRAITS screen” was VERY HELPFUL.

which personage is in Jita? open Tree Portraits screen and see.
which personage has a lot of $$$$$? open Tree Portraits screen and see.

which personage I logged in recently? that one on the left!

which personage I did not log in for a long time? that one on the right side! please log in and restart planetary extractors!

NOW ALL THAT__ HELPFULL__ THINGS ARE GONE!!!

you release manager is MORAN