Payment in the shop not working?


tried to by a package at the onlineshop (Winterfest) used firefox and chrome.
deleted cookies, addons etc. I get an timeout error message after choosing payment method.
eneybody else have the problem? is it a general problem atm?

thanks in advance


If you are using a credit card it’s almost certainly because your credit card is flagging the transaction and you need to call them and ok it.

I am not getting to paypal or could input my card data - before that is the error

Use a different browser

1 Like

As I wrote already used firefox and chrome (and different devices)

1 Like

Well, at some point you might want to file a support ticket.

1 Like

i have the exact same problem i cant buy any plex because the redirect to the payment gateway after clicking pay with paypal ends in a website timeout :frowning:

NGL guys I use Markee Dragon for 2 reasons really.

  1. They are a US company so things won’t be flagged.
  2. They sell omega TIME not a renewing subscription. Perfect for people who don’t like subs and forget they have them.

CCP is known for many late payments of goods and I have seen so many people in help chat ask about where is the stuff they bought.

Same here.

This site can’t be reached took too long to respond.

I then got a code from Marquee Dragon, but code activation also does not work… Too many redirects.

No matter what browser I use, it’s broken completely and I can’t get Omega.

1 Like

jep, here too, cant buy Omega, want to re loog in … thats bad

Same here. CCP ■■■■■■ up payment.

Just decided to give this company some money but I am not able to :smiley: thats funny. Both card and paypal options are dead.

1 Like

Feels like everyone’s on vacation – my ticket’s been open for 3 days now. It’s crazy that they’re not fixing things faster, especially when everyone’s at home trying to game. I bet they’re losing a ton of cash over this.


Still not working. Got a useless reply on Saturday. waiting since then to get a new reply.

Can somebody pay in the shop and if yes, which browser did you use?

I try to pay for Omega for 3 days, not working as of 5 mins ago.
I tried Firefox & Opera, Paypal & Creditcard, no joy.

Looks like the redirect to ingenico is the problem…

I have the same issue that the redirect to the payment service provider ends dead. I have tried at 3 different PCs with different browsers on each. It seems it relates to my internet provider, now Vodafone, ex KabelBW. I have reported the issue to CCP by opening a ticket. After I told them that I sucessfully bought Omega via my mobile phone (via O2 network), they closed the ticket. It seems they are not really interested in the case.

Mhh they raised the prices 'cause they need money to pay their bills.
But it looks like they don’t need my money in the future. :rofl:

CCP does not really care we can’t buy omega…

Markee Dragon is way more reliable. (No I did not get paid to say this.)

US based. You buy omega TIME not a subscription. So, you don’t have to remember to cancel your sub.

You can find a list of third-party sellers on CCP’s website.

Been having the same problem for the past 3 days now. I’m trying to get the gold starter pack on sell. I accidently put my childhood zip code subconsciously. So I called my bank cuz the over seas gets flagged from time to time. Found out CCP was kicking the payment cuz of the wrong zip code. I tried 3 more times with the correct info. Still did not work so then I went and got a new card and low&behold its failed again. So it looks like I’m not getting a discount. I’m out of omega so not much I can do till CCP shuts up and takes my money. how long did it take before it got fix for any one?