Seekers Investigation Glitch


(Demoy Sephiroth) #1

Hello folks,
I just started playing and I was doing the Seeker Investigation missions when I got to the “Upgrade” part when it says that you will be rewarded a new frigate plus, and I follow the instructions it gives me but when I attempt to redeem anything it isn’t present for me to redeem.
I have tried the restarting the mission several times, undock and redock with the station, but the reward still isn’t present for me to redeem.
Any ideas?
Has anyone else had this same problem?


(Leah Crowleymass) #2

I just spun up a new character to see if I can help, but I want to make sure I understand what you are saying.

Have you had any problems redeeming or finding the other items that you earned during the mission chain? Are you looking in your Ship Hangar or your Item Hangar?


(Leah Crowleymass) #3

OK, so I just plowed through this new NPE (and wow, is this underwhelming compared to the old one).

I completed the “A Rift In Space” mission and then docked.

I got the notification that new redeemable items were available (incidentally, pressing Alt+Y will open the redemption window as well), and saw a couple of modules and a frigate were available to redeem. I did so and the modules would up in my Item Hangar and the frigate is in my Ship Hangar.

So, all appears to be working for me.

Double-check both your hangars to see if it’s waiting for you there.


(Demoy Sephiroth) #4

No other troubles for items besides they sometimes to pop up till you pull of the agency window.
And yep, I was looking in both sections.

I’m not sure what exactly is supposed to happen, but it just says that we have a gift of a new frigate and modules when you dock at the station. I did so and followed the instructions but there was nothing to redeem.


(Leah Crowleymass) #5

Hmm, this does sound like a bug then. As I say, after completing the “A Rift In Space” mission and getting that message, I docked and got the notification that new items were waiting to be redeemed.

Out of curiosity, did you inject the skill book for the frigate and start training that? It shouldn’t have anything to do with the items, but I’m just curious.

I would suggest trying to log off, relaunch the client, and log back in to see if that causes them to pop up. If not, file a support ticket.

I assure you, the game gets MUCH better than this and I’m sorry you’re having troubles so early on.


(Xeno Ceph) #6

I have the same issue as well. Presuming its the 125mm railgun, Merlin frigate and the charges that I have gotten prior to the ‘Upgrades’ mission, I did get the notification on having more items to redeem when I docked but there was nothing in my redeemables. I have done what the steps told me to do with these 3 items but I still was not able to proceed to the next mission.


(Demoy Sephiroth) #7

Hello Xeno
Leah helped me by meeting me and providing the reward after she did the same mission. It is a glitch and it kind of is just how it is.
I did not find out how to get past the glitch. However, a side note, that after Leah provided the same winnings that the mission is supposed to give, the “upgrades” mission showed complete.
It is very strange. Leah stated that the missions systems had undergone an update so it is possible.


(Leah Crowleymass) #8

Yeah, I don’t know what’s going on here. As @Demoy_Sephiroth says, I rolled a new character and ran through the missions to that point to see what was going on and everything worked OK for me- the items showed up in my redeem queue and I was able to get the into my hangar. Then, oddly, when I gave the items to Demoy, that completed his mission.

Since this has happened to two of you now, I’m calling this a bug and would request that you fill out a bug report so that this can be investigated by the devs. But since it worked fine for me, I can’t say that this is something that’s consistent for all players.

It’s definitely not cool for new players to be running into issues like this when they are just getting started so I’m sure the dev team wants to get it fixed. Filing a bug report will help them get some info to address it (hopefully).


(Goggo Isu) #9

Hey Man,

I had exactly the same issue and I managed to get it working by doing the following:
*boarding the Merlin,
*open fitting window,
*removing the turrets and then re-adding them by ‘dragging them from inventory onto ship in fitting window’ like Aura says…and the mission completed.

Hope this helps you the same as it did me.

Good luck


(one above alll) #10

I did everything again and again …with auras golden words in my head…but still the same problem… this game simply declining me😢


(Markus Reinhart) #11

If you’re struggling with the current tutorial/NPE, it’s not you. I made a thread on it a while ago which got instantly closed due to ranting (they were right in making that call, but I was so pissed at the ■■■■ CCP had pulled with the NPE).


(JP Esquire) #12

I had the exact same problem and opened up a ticket with the help center - after some very quick replies (impressive) and a couple of tries they fixed it and I rejoined the tutorial at the next step.

While we are on the subject of the Seekers tutorial, I cant seem to get past a stage a few down on the list - I have to kill three ships but the last one keeps running away staying out of my range. The ship I was told to use, the ship they give you in the Upgrades stage, does not have after burners so there is no way to increase speed. As all newbie’s say, I am sure I am missing something, but what am I missing? thanks in advance.


(Pompslayor) #13

I have a newbe in my corp that has the same problem with this mission… he is so frustrated ready to dispose of the game… Lord Monte Oveart


(Boomer Fox) #14

I had the same issue, but somehow managed to get through. I repackaged the ship, made it active again, entered the ship, slapped on 2 gun turrets, and then added ammo. It was after the ammo that it finally registered for me. By the way, the key might actually be having two gun turrets? I’ve tried only one before, thinking that was enough, but that didn’t work.


(Valkyrie Zeta) #15

Just like what @Goggo_Isu did, but I did a something different.

  • Take a Frigate ship and assembled it. ( The one you got during the Agency missions.)
  • Put on a 150mm Carbide Railgun. ( I actually fitted this weapon and a 150mm ‘Scout’ Accelerator.)

After doing this i completed the Upgrade section.

I hope this helps.
-VZ


(Nadeko Hakomairos) #16

Minutes ago I unpacked a Merlin, opened its equip interface, and dragged 3 x 125mm Carbide Railgun I in high slots.
The quest was marked completed before I fit the gun with ammos.
Hope it helps.


(DetKhord Saisio) #17

I just ran through the tutorial and found this same issue. It seems Aura (helper NPC) offers assistance during the tutorial, but it seems to me Aura can lose correct timing for events when tutorial quests/missions are not completed in a timely fashion. When I first did the tutorial years ago, it was seemless and picked right up where you left off.

Now, it seems to have some sort of minor timing glitch or similar. So anyway, here is what I experienced:

Aura says to redeem a new ship, turrets, and ammo. The Agency window also says to redeem your items. If I had to guess, the events are not completing the Aura and The Agency window [The Seekers Investigation - Upgrades]. So after redeeming the new ship, turrets, and ammo, I opened the fitting window then fit the turrets and ammo. Aura stepped forward, but The Agency window does not.

To fix it, I removed the ammo and turrets, then fit the turrets and ammo for the new ship. That completed The Seekers Investigation - Upgrades. I hope this helps.


(Aim eYacht) #18

I’m an idiot and sold the items I got, now I can’t complete the mission. I’ve purchased a new merlin from market, as well as 150mm carbide railgun. Jumped in the ship and fitted one turret, and it didn’t complete. So now I can’t progress cause the items are gone I guess.


(Aim eYacht) #19

NVM, taking the turret out, changing ships, then getting back in the merlin, and refitting the 150mm turret, that I purchased, worked. It’s all good now.