Singularity Not Sending Verification Codes?

Attempting to log on to Singularity for the first time using this account/character.

The account info is good. The email address on the account is good. CCP has been whitelisted and spam folder is empty. Account has been continuously subscribed for more than 5 years (continuous Omega status).

Attempting to log in gives this message: “Please enter the verification code we just sent to your email address.” Hours later, no code.

Contacting Customer Support was worthless. Rep said I had to wait on a mirror. (Again, the account has been in continuous paid, active status for more than five years).

Any help would be appreciated.


I tried to log onto Singularity earlier today (at least two hours ago) and had the same experience for what it’s worth. No code via email.

I’ve been playing and continuously subscribed since 26 March 2008 (nine years seven months, and also continuous Omega status)

I haven’t contacted customer support as yet though. Based on what’s written above I wonder if it’s even worth it.

Do you have 2FA set up? That should mitigate the requirement.

(if not, why not?)

What’s 2FA please? I’m dyslexic so I’m not so good at acronyms.

2fa is two factor authentication. when you login you get short-lifetime code to place along password - this is to prevent you from losing account to hacker

1 Like

When it’s switched on, Eve doesn’t do the email validation any more (you have to do it once. and then it’s done.)

Might take a while to sync over from tranquillity to singularity though.

Long term fix, rather than short term.

And it’s a good idea to have switched on. I recommend using it with Authy, so you can store an encrypted backup of the tokens online, and sync them to other devices, in case you lose your phone. (there’s a chrome client for it too)

We have located the issue and it should now be resolved.

If you are still not getting the verification emails then please submit a bug report and we can investigate more.


This is happening to me as well. I just tried it.

so whats going on with this im still getting this problem. kinda annoying missed a mass test cuase of this .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.