Spacemouse change not respecting camera inertia

It looks like the new changes for Spacemouse support aren’t actually respecting the inertia. Or if they are, there needs to be a setting to drop it to zero. One of the great things about using a Spacemouse was how it moved the camera through space like a CAD program. Now, there’s no way to control exactly how the camera is working. No matter what settings are used, small motions of the spacemouse send the camera zooming way out or way in, and skating past whatever you want to look at.

I see what you mean. No matter what you change the acceleration to, the camera still takes it’s sweet time coming to a stop. The only question is do you want to wait 4 seconds, and 45. Don’t get me wrong, I think the feature will be helpful for getting more graceful camera stops and changes in camera direction, but having a setting that causes the camera to immediately respond to your inputs would also be nice.

I also noticed that the zoom in and out seemed to go a lot faster than the other camera movements. So, I had to manually adjust the speed of that particular camera movement in the mouses properties.

Anyway, you should probably post in general feedback about this.