Updates To Minimum OS Requirements For Mac Users

(Bingham McSnuggles) #82

that might be an OS issue if u also use high sierra.

also i get the feeling ccp didnt have the time to update the launcher for the newest OS´s…maybe they force macusers to use the steam launcher in near future…i dunno. but im pretty sure we have to wait for a fix…or buy a windows pc…or just quit eve vOv

(Priscilla Williams) #83

10.9 is the latest OSX version I can run. Apple got downright retarded starting with 10.10 and it doesn’t support any of the software I need for work. I can’t partition a different version because (while it SHOULD work fine) the new OSX erases the partition and controls the entire HDD. So, for me, its either find a way to make EVE work on 10.9, or I guess I’ll just never get to play again. What jerks.

1 Like
(Bingham McSnuggles) #84

also mac OS is case sensitive . so doublecheck if u used the correct lower/upper case letters

(Bingham McSnuggles) #85

oh. well then i have sad news for u. 10.9 isnt supported and wont work for eve anymore

(Bingham McSnuggles) #86

you can run it via bootcamp though ( which runs also much smoother on macs then playing eve in wine wrapper)
also its more like Apples fault, for forcing companies to adjust for the next OS Mojave…

quote if ccp falcon

:That is correct; Apple sent out the announcement email of macOS Mojave 10.14 tonight and this change in minimum requirements on one hand ties into that expected announcement and on the other hand relates to updates of libraries we are deploying that no longer support 10.10 and older.

(Priscilla Williams) #87

Bootcamping isn’t possible on my machine. It can bootcamp windows 7, but only from disk, as the GENIUSES at apple removed the ‘iso to flash drive’ option from bootcamp for iMacs. So, I have no way to ISO my Windows7 onto a flash drive for installing, and my DVD drive went out years ago. (Third time. When the warranty went out, I decided screw it, apple hardware just stinks.)

External DVD drives use USB3 connections, which is useless for bootcamping because Windows7 only has USB2 drivers. USB3 is only backwards compatible if the USB3 driver exists in the system it is connecting to.

I didn’t know 10.9 is no longer supported though… that just raises all sorts of concerns not related to EVE. Geez, I can’t afford a newer computer…

(Bingham McSnuggles) #88

thats news to me. u can still simply use an iso image of win7/8 and install via bootcamp. no optical drive or dvd needed.

but i feel your pain, i actually cant afford a new machine either…but i guess this christmas i have to take all the real life iskies i can gather, and buy me a windows based machine, since i only had issues and headaches with this ■■■■■■■ mac, since i bought it. never again an apple product.

(Priscilla Williams) #89

lol… Mac is magical for like a year. Then it’s a total nightmare.

I’ve tried creating an ISO of my windows and doing it that way, but Bootcamp will only take one it creates from the disk. Since my version of bootcamp can’t create the ISO, the ISO I create through another program doesn’t work.

(Bingham McSnuggles) #91

i also just checked the bootcamp assistant, your right u need a dvd…:frowning:

(Bingham McSnuggles) #93

CCP_Falcon . or anyone at CCP…What will be the ETA for mac useres to be able to login again?

(Bingham McSnuggles) #94

Ok finally i got it to work.

  1. open launcher
    –> settings
  2. open shared cache
  3. u should see a " reveal in finder " button. hi it
  4. should show u all previous wine installations/launchers of eve, chose an old one, let it update, and manually add your accounts then in the window which should popup whne u hit the login button then.
    worked for me.
(Kipsley Caton) #95

Firstly… Thank you to zluq zabaa for the work you have put in to finding a work around for the launcher. My computer skills are a bit… meh, but I was able to follow your directions. This is what I ended up with however…

Macs-Mac-Pro:Applications macpro1$ cd EVE\ Launcher.app/
Macs-Mac-Pro:EVE Launcher.app macpro1$ cd Contents/MacOS
Macs-Mac-Pro:MacOS macpro1$ pwd
/Applications/EVE Launcher.app/Contents/MacOS
Macs-Mac-Pro:MacOS macpro1$ ./evelauncher-s
-bash: ./evelauncher-s: No such file or directory
Macs-Mac-Pro:MacOS macpro1$ ./evelauncher -s
[S_API FAIL] SteamAPI_Init() failed; ipcserver init failed .
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dylib.

The Launcher opened for me but when I clicked “Log in”, all i got was a white screen with nothing in it. I will try to search other sources to find a way of logging in.

I do have Steam but Eve was never hooked into it so I have not yet looked into anything about starting Eve using Steam. I’ve just never done that.

Sooooo… Yesterday I spend 11 hours trying to update my early 2009 Mac Pro 4.1 from El Capitan to High Sierra. I tried to flash my system to 5.1 with no luck. Then I found a work-around online that allowed me to install High Sierra even though my Mac was still a 4.1 machine. It worked \o/. Thing is my really expensive graphics card is not supported in High Sierra apparently and only my old 512 mb card would work.

Luckily I had cloned my drive before starting this and so was able to restore back to El Capitan. Given my Mac runs OS 10.11.6 (El Capitan) I figured I’d be fine as CCP said it would still work. Sadly it does not work for me.

So where does that leave us dedicated Mac users who would love to continue our Eve experience? Buy a newer Mac? Upgrade my Graphics card to a High Sierra comparable one? Move to Windows? Or do we just forget all about Eve and our accounts?

I played Eve every day. Loved it. I’m Omega and pay an annual subscription. My one and only account could fly anything from a PANIC fitted Industrial Core II Rorqual to a fully fitted Rattlesnake. I really would not wish to simply walk away from it.

So what do we want from CCP given we can appreciate their reasons for the changes? If the problem is simply with the launcher, how about access to an earlier version of the Eve Launcher that has the automatic update feature disabled? Perhaps that could be permitted for a few months till something more permanent is worked out or we can upgrade (if absolutely needed). 24 hours notice was a bit rough and gave us no time. And many who did upgrade to High Sierra are seemingly having difficulties logging in.

Many online games do have access to older versions of their launchers for those on older systems, be they Windows or Mac. I don’t see why CCP can’t do the same.

I will today still keep trying to find a “fix” so I can log in on my old Mac Pro. I just can’t afford to run out and buy a new machine or a new graphics card that is supported under High Sierra, so this has just been my 2 cents. Not happy. If I can’t get this to work I will have to cancel my Omega subscription. It is set as an auto-payment each year, so please CCP, don’t go billing us poor Mac users if we can’t even get in to the game.

1 Like
(Bingham McSnuggles) #96

try the fix i posted, worked for me.

also its not ccps fault. u can blame apple for this.

(Kipsley Caton) #97

OMG! That worked… I’m in.

I found my Eve Launcher in Applications and opened it.
I then did as you suggested and went to the “Settings” tab in the Launcher.
I opened the Shared Cache and found 4 older versions of the Launcher. I chose one that was from January of this year.
I double clicked on it but all I seemed to get was a window with computer stuff written in it. Kinda like a txt file, so I closed it again.
I then just figured “what the heck” and opened the Eve Launcher. (It updated for a sec as it usually does) It had “Log in” but my account name was not there.
I hit “Log in” anyhow (as what did I have to lose?) and suddenly my account name was there.
I hit the button to log in and it worked \o/.

Now I’m afraid to close it. Lol. Will it continue to work? I just have no idea.

1 Like
(Bingham McSnuggles) #98

i tried closing and re-open, worked. just had to add all accounts manually :slight_smile: glad it worked for you too.

1 Like
(Kipsley Caton) #99

Yups. Worked for me also. I had to log off and do some stuff around my house, so after an hour or so tried to log back in.

Opened Eve Launcher from Applications.
Clicked “Log in” (as that is all it says… No account shown).
Got that white screen. Was blank for only a second or two then it asks me to log in manually.
Logged in and it started like normal.

** Does the happy Kipsley dance.

2 Likes
(mthunt dickens) #100

So how long should this work around last for? And thanks to those who figured it out!

(Bingham McSnuggles) #101

i hope ccp patches stuff fast, otherwise we mac people have to live with the work around :confused:

and also thx to Zluq Zabaa, for all the time invested to help us.

1 Like
(Bingham McSnuggles) #102

it seems the launcher doesnt work perfectly with this workaround. i just tried to join a player chat channel…and it opend 1 version of that channel for each character in this channel…so it opened 178 chat windows…

(Bingham McSnuggles) #103

welp. client is complete trash now, after downtime. takes around 10 min to load an account. and ingame fps is like 1fps…