Version 20.06 - Known Issues

I can get to the AIR Career Program UI but is showing that I have done nothing. It is showing me that I still need to do the starter career missions and I have done them all. Is this a bug or is not fully implemented yet?

Performance is dire, ship invisible for the first 5 minutes. Selected item icons not resolving. Could go on, much more. Will submit with loglite. Basically unplayable.


First undocked and my ship (Gnosis) was invisible except for the missile launchers on the hard points and the blue light effect on the back of the ship. The station was also not visible, only the lighting effects after undocking. When I warped to a jump gate, only the lighting effects were visible, but not the gate structure itself.

After jumping to another system, during which the jump tunnel cut-scene did not load, my ship was invisible, as well as the star gate, stations, and other ships. The overview was also empty, but the call-outs pop-up when I moved my mouse pointer down the left-hand column.

I tried disabling the DirectX12 setting in the launcher, and restarting the client, but the same issues persisted.

Update: The more time I spend in the game, the more the graphics items seem to be gradually loading and displaying again. My “resource loading” indicator in the lower left above the clock seems to be working overtime. After some more time and a few more jumps, it looks like the graphics items are starting to work properly again, including the jump tunnel cut-scene.

Still have not re-enabled DirectX12 though…


It was not programmed to be retro-active so it only looks to see from today if you have done them.

AIR has apparently stopped tracking anything.
Reprocessing, market buying, salvaging, none of it is registering.


yet some achievements don’t make much sense that way, like joining a corp


That will get patched thou, they have corp history for that. I just hope all this tracking of achievement’s doesnt slow down network traffic lol with all the checks xD

No idea thou.

all those checks could/should be server side

1 Like

Seeing an issue with the tether animation not showing up when zoomed out only a little bit. Making me think a lot of ships are untethered when they are.

Thanks @Jasu_Akiga ,

By running this launcher verification function (located in [Launcher Settings][Tools/Cache][Shared Cache]), I was able to recover 15 GB on my SSD!

It’s cool.

Ully Loom

OK a big load of my missing AIR stats suddenly appeared all at once.
It’s not totally broken, just lagging way, WAY behind.

1 Like

Same problem. With two accounts open on different monitors, selecting either causes the other to drop to single digit fps. If i select a third monitor and unfocus eve accounts, both unfocused eve accounts go back to full fps.

1 Like

So, I tried traveling a bit and things got worse again. Ship, gate, and station models not displaying, screen not interactive after jumps, overview is blank again, module HUD disappeared a couple of times… Still not really playable. Long pauses of several minutes waiting for enough things to load to interact with the overview again. It’s like items seem to need to reload for new systems or constellations or regions or something.

No tether visual effect while being on tether (EBR-235639)

The game seems to go very laggy since the update, and I have all the graphic settings options on low.

1 Like

i have exactly the salme problem with a 2070 S with 2 monitor one FHD and one WQHD
with D3D12
when the FHD is focusing the WQHD client drop to 4/10 fps
when the WQHD is focusing the FHD drop around 30 fps
when none of them are focused the framerate is under 10 fps for both

with D3D11
when the FHD is focusing the WQHD client drop to 55/60 fps
when the WQHD is focusing the FHD drop around 55/60 fps
when none of them are focused the framerate is around 55 fps for both
my driver are uptodate

Having the same issue. FPS drop to single digits on any of the unfocused clients. Switched back to Dx11 and it now works fine again.

Setting ‘Present interval’ to interval immediate seems to help but it’s still pretty bad.

Ill stay with dx11 for now

Ryzen 7 2700x
RTX 2070S
Windows 11

I have the exact same experience.
2 accounts on 2 monitors. When 1 was active the other lagged badly. And the other way around.
But when i put my cursor on a third monitor the 2 account monitors both behaved fine → no lag
I disabled the dx12 in the launcher and the lag issue seems resolved now.

My present interval have always been at “interval one” on both accounts, and that hasn’t changed.

AMD Ryzen 5 5600G 3.9 GHz
RTX 3060

1 Like

I cannot do any of the career agents because I have done them already, and I wish that the AIR Career Program would update to everything I did in the past 7-8 months

1 Like

As at 00:42 this issue has been resolved.

The launcher is having issues today: