Version 21.05 - Known Issues

Hello everyone,

Here you will find a list of any known issues as we become aware of them for patch 21.05.

Please use this thread for reporting and tracking of any issues.

Quick info:

Quick Info:

Other Information Threads


Known Issues:

There are some cases where the launcher cannot download parts of the Viridian patch

Mining lasers do not work. A fix for this our highest priority.


  • Hangar atmosphere audio can be very loud upon docking
  • Various atmosphere audio is persisting longer than intended and following the player


  • Structure modules are not updating correctly after SKINR nanocoat application. Any applied nanocoatings should be rendered automatically once the issue is resolved
  • Applying SKINR nanocoat to structure causes corporation/alliance banners to slowly fade away
  • Certain station interiors appear too bright when reflections are set to “High” and “Ultra”
  • Preview for the Sanguinary Savant SKIN’s are currently not displaying correctly.


  • Items purchased with Corporation LP are currently delivered to the purchasing character’s personal Item Hangar

Native Mac Client

  • Several graphical effects (for some turrets, smartbombs, wormhole effects) are not displayed correctly on Mac clients

User Interface

  • The EverMarks donation tab of the Corporation Wallet may take a longer time to load when first opened that session.
  • Searching for Corporations in the EverMarks donation tab of the Corporation Wallet may take longer than in other areas.
  • The Loyalty Points Store window may take longer to load with the affordable filter and corporation wallet checkbox active
  • Loyalty Point are not formatted correctly in the Wallet
  • The SKINR window may not appear correctly when opened during a session change
  • Quitting a corporation does not remove its corp projects from your Opportunities (until after relog)
  • Pinning the Corporation and Opportunities window to one window causes the buttons to not work properly
  • The info panel Travel objective widget doesn’t update when changing route settings (until after one jump)
  • Missing menu when clicking ‘three vertical dots’ menu button in the Opportunity Details window for Homefront Operations and Combat Anomalies while in space
  • Missing options/buttons to track/untrack after warping to a Homefront Operations lobby (until warping elsewhere)
  • Accepted agent missions are not added to the Opportunities Active tab (until they’ve been opened in Opportunity Details)

Corporation Project

  • Unable to search for wormholes in the solar system bar field
  • Missing translations for Japanese
  • Progress is not counted when the Militia is entered into the Damage Capsuleers project
  • Capsuleers are able to see the Goal ID in the three dots menu

Homefront Operations

  • Objective counter does not update in the Gallente ‘Emergency Aid’ Homefront Operation
  • The decloaking effect in the ‘Suspicious Signal’ Homefront Operation can take some time to start, this can make the conversations not line up with the scene
  • Homefront Operations lobby objective can remain after activating the gate
  • Delivering multiple items simultaneously does not have the counter update correctly in the ‘Emergency Aid’ Homefront Operation
  • Homefront Operations do not appear/disappear immediately in Opportunities browsing window when setting/clearing destination
  • Homefront Operations’ Warp to Site button in the info panel does nothing when clicked (when the Opportunities window is closed)

*** Removed all System Index Cost modifiers. *** - STILL ALIVE

1 Like

Mission side thingies in the UI lost functionality when they were “upgraded” - before this patch we used to be able to know that the mission was completed or not based on the icon it had like this:

This is a completed mission, and the uncompleted was showing a different icon (which I don’t have a screenshot of because nobody thought it would be broken).

After the patch:

Why was this even changed?


Clicking “track” in Opportunities when doing a combat anomaly does nothing.

In fact, I managed to “track” the same combat anom 4 times, with 4 different drop downs on the Info Panel, none of which had any information on them.

And they persisted even after the anom despawned.

And the anom was still in the opportunities UI and clicking “Untrack” did nothing.

Glad to see that the same level of QA is being upheld as with every other release.


This is a major issue for me that I now have to manually check each mission by talking to the agent. This makes the UI worse to use, slower, and less effective.


After the update the game started to freeze (crash) a lot. And it seems like the issue is sound-related. Confirmed by my corp-mate. Disabling the game audio fixes crashes.


Launcher wont launch the game client.


There’s no indication the launcher is patching. I am considering reinstalling the launcher from steam.

EDIT: restarting my computer solved this issue. So there seems to be an issue with active cashing.

I had this issue and cause of this after loggin in my client frozing after few minutes. After uninstalling this issue is on downloading process in launcher. Shared cache not available.

1 Like

New live version of the client is missing a Beta tag to indicate the patch should still be in testing due to the number of known game breaking bugs.


The new replacement for the journal isn’t helpful either:

One of those missions is just accepted, one is completed. Which one?
All of these missions expire at some date. What date?

Not to mention this dumb window can’t remember it’s filtering settings, not even after closing the client, but just after closing the window and opening it again.


New bug: when i warp in to combat anomaly, i have ~10 seconds lags, significant drop FPS, impossible use modules / warp out, or it will have effect when lags gone.

1 Like

Please Understand CCP, Showing Data in less Space is a good thing, we all dont have 4k screens, or want to click everything to find information that was right there before, even if poorly understood


Regarding to previous comments launcher log

1 Like

So we get to chose between not playing or maybe playing but at the cost of beta launcher nuking all our settings and redownloading the entire game (seems to happen when EVE location is non-default one).

Edit: removed a spare “a”


Q: have you tried turning of dx 12?

That influences the game. Doesn’t help if you can’t even update eve due to Launcher being messed up.