Evernus [3.8 release] - the Ultimate Market Tool

esi
tool

(Catherine Solenne) #524

Just realized those are corporation contracts and you’re absolutely right there, once populated by one character they will remain in the server-side cache until they’re invalidated (1 hour). It’s still in the responsibility of the client to cache them locally, of course, but I’d definitely say the cache time of this particular endpoint could be extended quite a bit.

@Pete_Butcher are you currently using Etags for caching? Still will only be isolated per client since this isn’t a web app, but could help with the issue. I’m admittedly not sure if you’d still hit monolith rate limiting when using if-none-match, but it’s worth a shot.


(Pete Butcher) #525

I’m only using the Expires header. Should be enough.


(Catherine Solenne) #526

But as you pointed out the items are immutable. So, using the Expires header you’ll be re-fetching the same, immutable data every hour. If you use ETags you’ll only ever fetch it once since the ETag shouldn’t ever change after that initial request.


(Pete Butcher) #527

That’s true, yet it’s still a workaround for a problem which shouldn’t exist in the first place. We were told there is no rate limiting, so there shouldn’t be any rate limiting. Period.


(Object640) #528

Still sitting banned for repeated macro use. CCP Peligro sent me copy paste thing and nothing more… I have submitted additional info with screenshots of Evernus and my EvE client and explained that I was unfairly banned… Quiet… Ticket is opened, 3 weeks of ban…

User EVE-SSO-CONNECTION is banned pending investigation
Last login: 2018.06.12 13:10
Number of visits: 2630
Reason: You have been banned permanently by CCP Peligro. The reason specified was: Repeated Macro Use - Permanent suspension


(Madhibby) #530

I get the above image ever time i run import data for market analyse. I have left it on for days and it never finishes the data download. Iran it for only one region and still the same. any help on how to rectify my problem.


(Richard Price) #531

since yesterday night on every charcter i get this error https://i.gyazo.com/90f4c1aea61fa84f901e3b2dea1007b3.png , someone else when try to update corp orders?


(Cara Cassidy) #532

Got the same problem, with past versions as well.

edit: After some more testing I found that v3.0-rc2 is working for me, all later versions get stuck waiting for 130-133 server replies, even when left running over night.


(Pete Butcher) #533

Minor maintenance release is here:

[changed] updated ESI endpoints


(Richard Price) #534

Hi, after the update all my corp order are multiplied by the characters in the corp, that have “director”


and only one charcter is added to evernus.
i tried to delete all charcters and added on and deleted the whole orders and restarted the import and get same result


(Pete Butcher) #535

Interesting. I don’t know if it’s a bug or a feature of esi. If anyone finds out, let me know.


(Richard Price) #536

ok, i dont know how or why, but after waiting some time… everything is now fixed…


(Helena Audane) #537

I just installed Evernus for the first time, looking good so far. However, it only displays the journal and transaction entries (character and corp) of the past two months. All the data from the the last few months/year is not available? Or do I have to import that manually?


(Pete Butcher) #538

It’s not available.


(Inigma Gallente) #539

Getting Waiting for 135 history server replies. Log shows:

[warning] 2018-07-16T23:55:15 5232 Error for request QNetworkReplyHttpImpl(0x14b467092c0) : “/v1/markets/10000002/history/” QMap((“type_id”, QVariant(uint, 47707))) : 404 “/v1/markets/10000002/history/?type_id=47707: Type not found! (SSO: 0)”

Getting a 404, else I don’t think it’s finding the type id…

When I drop off Implants category I am able to get past this. I will need to drill down later to find the actual item it may be referring to.


(Martin Gregor) #540

How exactly does one import citadel data?
It shows my orders, but always “unknown location” regardless of what I press in the citadel manager.

And in case of a found citadel (Perimeter tradehub) it always shows “Data too old”…


(Richard Price) #541

it seem to be impossible to import all contracts from corp… i have over 300 contracts, and never get all of them… may be there is a way to check only one contract at same time and then the next to not get throttled?


(Erytnicmcire) #542

Is it possible to make a downloadable 3.8 version for OS X, please?


(DelBoy Trades) #543

Is anyone else having trouble with Evernus? I’ve only recently downloaded it but I am unable to import data, it appears to be ‘doing something’ i.e. numbers of data/history is increasing but it inevitably freezes and doesn’t complete. I can however import my character data. Any help would be great, would love to get this working for market analysis. Failing that, any advice on where to find market analysis elsewhere? Thanks


(Damilola Karpow) #544

do you have bug tracker?
OH. I SEE… bitbucket… so… probably i can go there

i see “transaction list”
many transaction are with “–location unknown–”

yes, i see there is “citadel management”,
and i can put proper name there
it asks “Id:”
so…
where do i get it?
may you display location like “–location unknown–id–32323232323232–”