Version 21.02 - Known Issues

The same text colors are now used for transactions in the different tabs of the Wallet window.

You choose the worse, harder to read and distinguish color theme instead of the easy, bright, popping theme to fix this inconsistency issue. Great job, CCP, great job.

  1. The ship skin preview and menu items on the left of the window are overlapping the actual window border. See left, right and bottom. This has been an issue for the past 2-3 weeks already

  1. Having multiple overview windows causes massive UI lags when updating filters.

  2. There also seems to be no apparent way to remove an overview window once it has been created. If I remember correctly, there was a right click menu, when clicking a tab in a window that let me do this. This menu is gone. edit: looks like this was an issue after the update. Had to reset my overview to fix this

  3. After the patch was applied, 3 of 6 overview windows have been removed. The leftover windows have their tabs reset back to default.


Known issue:

  • The location window can be opened with the “L” key.
    It does not close with the “L” key instantly after opening.
    One has to click the desktop space view first, before “L” works again for closing the location window.

A laudable improvement acknowledged:

  • Two "Warp to …) context menu entries (1 Warp to 0m; 2 Warp to …(distance submenu)) have been joined into one “Warp to 0m” + > expandble submenu for other istances context menu entries. See, CCP, you can do it right, if you listen to your humane brain instead of your political brain.

The colors and contrast seem to be washed out in the market window now. And I did have the Photon UI already enabled before so not sure what changed.


This is bad CCP. 99% of overview packs developed by players use html tags for readability. You must know this, since you reviewed said packs for creating the new default overview settings.

Now, the tags STILL WORK. As long as you load the settings directly from a .yaml file. And never touch that field in-game.

I put that on lack of communication between whoever worked on overview, and photon ui team.

Edit: it’s actually worse. Changing anything within that “Tabs” setting window, breaks the overview. Regardess on whether the tab name field was even touched.


I will quote some of my previous posts, with IMHO questionabe design choices, that remain in effect in photon:

^ this one is especially egregious imho.

[for this one, i have new contacts window bound to alt-q; new locations window bound to alt+e; and “local locations” bound to L.]


I’d prefer the old way of getting to the “show all brackets” functionality. Instead of a multi-layered menu. Why? Because it’s somethimes critical to do it quickly. And you were able to check on the state of whether it’s on by simply clickling once.


Can’t change column sorting. I used Photon before today and had it in a different order, today it’s reset to the normal order and there’s no option to change it anymore.


They can still be re-ordered.
The column sizing/order/columns actually selected has all been indeed reset and that;'s a valid complaint.


OOOH, I couldn’t find it. Can’t remember if I changed it there before and forgot, or if they changed how to… change it.

Anyway, thanks!

The annoying part is, we need to apply these to each and every column separately.

Edit: and the column sizing is not saved within the .yaml itself. so there’s no way to hack around that tedium (it’s in the ui settings files; the char_data_id whatever files, you set it once, then you can clone it to other chars. But the file itself is a binary).


So, CCP:

So, the selected columns shown in the overview tab, their respective sizing, and ordering - all has been reset to default.
You now select what columns are visible on a per-tab basis. That’s great.

But there’s absolutely no way to apply the same setting to all the tabs at once.

So if you have, say, 8 tabs, you need to mess with that 8 times.

Also, the .yaml file that hold the overview settings, does not hold the sizing of each column [that is somewhat sensible, coz reasons]; but that means there’s no way to easily transfer the overview layout to your other characters.

Coz ■■■■ you, do that ■■■■ 8 times, times however many characters you have. [yes, you can do the char_data in the appdata ui cloning]

I will now have to spend like an extra hour to set this crap, and probly each and every tab will be just-not-pixel-perfect. So there will be some overview “twitching” when I change the overview tabs.

Then I will need to go to the /appdata/ and start the tedious ui cloning process.
Coz I’ll be damned if I’m gonna do it manually 6 times.

1 Like

The salt, oh the glorious salt :rofl: :rofl: :rofl:

Starting from simple one. Show special brackets (like moons in space) settings are not saved after relog.

But there is more serious problem than brackets.
Photon UI is showing misleading informations and/or misrepresenting available commands (like warp or activate).
Look at screenshots below:

Both pictures show identical situation (landing on militia plex).
When coming out of warp in Photon UI you can see available commands in selected item window that should be grayed out.
This is also happening when you eject pod from destroyed ship and you try to save capsule by preselecting celestial to warp to.
Warp or activate are ignored by UI but showed as available.
Old UI had no problem with this and also radial menu works fine.

I lost capsule to this bug and standard answer from GM was “our logs show nothing” unironically this is correct because UI is not registering any commands at that shor period of time (finalizing warp or ejecting capsule).

I raised ticket over week ago and had no serious answer, only automated message to clear cache.
I tested this on Sisi and TQ before todays update and after.
And yes cache was cleared.

So if you lost ship or pod while using new UI and you damn sure you’ve click that warp button open petition to ccp for reimbursement. I know its wall of text but it’s not easy to explain and now even to compare as they force Photon UI to everyone.

EDIT: example on video Photon UI bug - YouTube
EDIT 2: after last patch all works as it should but in patch notes they only mentioned docking
“The Radial menu dock function no longer appears to be available while in warp.”


If you want the game player numbers continue to decline, keep this attitude.


You realize at some point, old software has to be changed. The new photon, while not perfect is a step in the direction of CCP wanting to be able to easily alter/change the UI. With the old UI I’m willing to bet it was a pain to alter anything. Having a brand new one will allow them to make changes as necessary in the future and theoretically be less resource intensive.

Complaining about the new UI and being negative isn’t going to convince CCP to change it back (Not that they ever will) but it also makes them less receptive to feedback in general when the loudest people are the ones bitching over stupid things (Not saying you specifically just in general).

Also as a note, I hated photon when it was first released. Refused to use it. After the last forced Opt-out I began to use it and become accustom to it. Just use it and set it to how you’d think you’d like it and go from there. You’ll get accustom to it eventually.


I’m not compaining about stuff being changed. I’m complaining about the bugs that came WITH THAT CHANGE. Or changes FOR THE WORSE. Or questionable design choices.
How hard of a concept is that to comprehend?

Ergo, if you think, this is an unwelcome, counterproductive feedback; my answer is as in the previous post.

Keep that attitude, enjoy dwindling playercount.

Also, freaking read the header:
Complaining about people complaining in a thread for complaining about stuff that’s broken.



Just something simple…
I’d like to be able to tell the difference, without having to get within 2 inches of the screen, between whether or not a number is selected…
Not selected
I’ve tried every theme, most settings (brightness doesn’t seem to stick BTW), none make any difference.
Play “how many chars are selected…”


I love the new ui, for years I’ve had to wear glasses to play most games - Now when playing eve all the buttons are , massive and I no longer need glasses to play eve, the colour scheme are so washed out I turn all colours off except for black and white with adds a bit of fortnight nostalgia to the mix, I’m really like it , it reminds me of my old commodore 64 that broke and would only play in black and white


I thought known issues was for CCP to fill in rather than us minions, can they not be bothered to even write up or acknowledge the issues themselves